Skrypt kodowania Windows Media

Program Skrypt kodowania Windows Media® firmy Microsoft® to narzędzie uruchamiane w wierszu polecenia, którego można użyć do konwersji emitowanego na żywo oraz nagranego audio i wideo do plików Windows Media lub strumieni. Korzystając z programu Skrypt kodowania Windows Media, można:

  • Konwertować pliki z rozszerzeniem .wma, .wmv, .asf, .avi, .wav, .mpg, .mp3, .bmp i .jpg.
  • Przechwytywać zdarzenia na żywo z urządzeń.
  • Emitować zakodowane pliki lub zdarzenia na żywo.
  • Dostosowywać sesje kodowania, w tym określać profil, kodować wybrane fragmenty pliku, przycinać i zmieniać rozmiar wideo źródłowego.

W tej dokumentacji objaśniono sposób korzystania z programu Skrypt kodowania Windows Media. Zawiera on następujące sekcje:

  • Kodowanie plików i zdarzeń na żywo. Wyjaśnia sposób wykonywania podstawowych zadań kodowania z wykorzystaniem najważniejszych opcji wiersza polecenia.
  • Korzystanie z profili. Wyjaśnia sposób wykorzystania profili i zawiera listę wszystkich profili dostępnych w programie Skrypt kodowania Windows Media.
  • Zaawansowane techniki kodowania. Zawiera opis niektórych filtrów kodowania dostępnych w celu poprawy jakości wideo. Sekcja ta zawiera także wszystkie opcje wiersza polecenia dostępne w programie Skrypt kodowania Windows Media.
  • Często zadawane pytania. Zawiera odpowiedzi na powszechnie zadawane pytania na temat programu Skrypt kodowania Windows Media.
  • Słownik. Zawiera definicję terminów dotyczących programu Skrypt kodowania Windows Media.
© 2000-2002 Microsoft Corporation. Wszelkie prawa zastrzeżone.


Kodowanie plików i zdarzeń na żywo

Program Skrypt kodowania Windows Media umożliwia kompresowanie do formatu Windows Media plików z rozszerzeniem .wma, .wmv, .asf, .avi, .wav, .mpg, .mp3, .bmp i .jpg. Można przekonwertować jeden plik, wszystkie pliki w folderze lub podfolderach lub użyć pliku wsadowego do konwersji określonych plików. Można także użyć programu Skrypt kodowania Windows Media do przechwycenia zdarzenia na żywo z urządzenia. Zawartość można wysłać do pliku lub wyemitować.

Program Skrypt kodowania Windows Media jest instalowany w tym samym folderze co program Windows Media Encoder. Domyślna lokalizacja folderu to Program Files\Windows Media Components\Encoder.

Poniższe przykłady przedstawiają sposób wykonania różnych zadań z wykorzystaniem podstawowej składni wiersza polecenia:

Aby pobrać źródło z pliku i zakodować do pliku:

cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mójplik.avi –output C:\Moje-klipy-zakodowane\Mójplik.wmv

Można także podać ścieżkę UNC.

Aby zakodować wszystkie pliki w folderze:

cscript.exe wmcmd.vbs –input C:\Moje-klipy –output C:\Moje-klipy-zakodowane

Aby pobrać źródło z urządzeń i zakodować do pliku:

cscript.exe wmcmd.vbs –adevice 1 -vdevice 2 –output C:\Moje-klipy-zakodowane\Mójplik.wmv -duration 620

Aby wyemitować zdarzenie na żywo:

cscript.exe wmcmd.vbs –adevice 1 -vdevice 2 –broadcast 8080 -duration 480

Dodatkowe opcje wiersza polecenia można dodać na końcu podstawowego polecenia. Można na przykład określić, kodowanie CBR lub VBR, zastosować filtr usuwania przeplotu w źródłowym wideo, określić używany profil itd. Opcje wiersza polecenia można dodawać do polecenia w dowolnej kolejności.

Tematy pokrewne

  • Skrypt kodowania Windows Media
  • Korzystanie z opcji wiersza polecenia
  • Otwieranie okna wiersza polecenia
  • Kodowanie pliku
  • Kodowanie wszystkich plików w folderze
  • Przechwytywanie zdarzeń na żywo
  • Kodowanie wsadowe


Otwieranie okna wiersza polecenia

transparent programu Windows Media Encoder

Aby otworzyć okno wiersza polecenia

  1. Kliknij przycisk Start.
  2. Wskaż polecenie Programy.
  3. Wskaż polecenie Akcesoria, a następnie kliknij polecenie Wiersz polecenia.

Tematy pokrewne

  • Kodowanie plików i zdarzeń na żywo


Kodowanie pliku

transparent programu Windows Media Encoder

Aby zakodować plik

  1. Otwórz okno wiersza polecenia.
  2. W wierszu polecenia wpisz ścieżkę do folderu, w którym znajduje się plik Wmcmd.vbs, na przykład:
    cd \Program Files\Windows Media Components\Encoder
  3. Wpisz poniższe polecenie, a następnie naciśnij klawisz ENTER:
    cscript.exe wmcmd.vbs –input stacja_dysków:\Ścieżka\Nazwa_pliku_wejściowego -output stacja_dysków:\Ścieżka\Nazwa_pliku_wyjściowego

    -lub-

    cscript.exe wmcmd.vbs –input stacja_dysków:\Ścieżka\Nazwa_pliku_wejściowego -broadcast numer_portu

    Na przykład:

    cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi –output C:\Moje-klipy-zakodowane\Mój_plik.wmv

    -lub-

    cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi -broadcast 9090

obrazek „Uwaga” Uwagi

  • Jeżeli nie zostanie podane rozszerzenie nazwy pliku wyjściowego, odpowiednie rozszerzenie jest dodawane automatycznie.
  • Nazwy plików zawierające spacje należy wpisywać w cudzysłowie, przykładowo "mój przykład.avi".

Tematy pokrewne

  • Kodowanie plików i zdarzeń na żywo
  • Kodowanie wszystkich plików w folderze
  • Przechwytywanie zdarzeń na żywo


Kodowanie wszystkich plików w folderze

transparent programu Windows Media Encoder

Aby zakodować wszystkie pliki w folderze

  1. Otwórz okno wiersza polecenia.
  2. W wierszu polecenia wpisz ścieżkę do folderu, w którym znajduje się plik Wmcmd.vbs, na przykład:
    cd \Program Files\Windows Media Components\Encoder
  3. Wpisz poniższe polecenie, a następnie naciśnij klawisz ENTER:
    cscript.exe wmcmd.vbs –input stacja_dysków:\Folder_wejściowy -output stacja_dysków:\Folder_wyjściowy

    Na przykład:

    cscript.exe wmcmd.vbs –input C:\Moje-piosenki –output C:\Moje-piosenki-zakodowane

obrazek „Uwaga” Uwagi

  • Jeżeli folder wyjściowy jeszcze nie istnieje, zostanie utworzony.
  • Nazwy folderów zawierające spacje należy wpisywać w cudzysłowie, na przykład "mój folder".

Tematy pokrewne

  • Kodowanie plików i zdarzeń na żywo
  • Kodowanie pliku
  • Przechwytywanie zdarzeń na żywo


Przechwytywanie zdarzeń na żywo

transparent programu Windows Media Encoder

Aby przechwycić zdarzenie na żywo

  1. Otwórz okno wiersza polecenia.
  2. W wierszu polecenia wpisz ścieżkę do folderu, w którym znajduje się plik Wmcmd.vbs. Na przykład:
    cd \Program Files\Windows Media Components\Encoder
  3. Wpisz następujące polecenie, a następnie naciśnij klawisz ENTER:
    cscript.exe wmcmd.vbs -adevice numer_urządzenia_przechwytywania_audio -vdevice numer_urządzenia_przechwytywania_wideo -output stacja dysków:\Ścieżka\Nazwa_pliku_wyjściowego -duration czas

    - lub -

    cscript.exe wmcmd.vbs -adevice numer_urządzenia_przechwytywania_audio -vdevice numer_urządzenia_przechwytywania_wideo -broadcast numer_portu -duration czas

    Na przykład:

    cscript.exe wmcmd.vbs -adevice 1 -vdevice 4 –output C:\Moje-klipy\Mójplik.wmv -duration 620

    - lub -

    cscript.exe wmcmd.vbs -adevice 1 -vdevice 4 –broadcast 8080 -duration 620

obrazek „Uwaga” Uwaga

  • Można użyć opcji -devices w celu sprawdzenia numerów urządzeń dla urządzeń przechwytywania audio i wideo w komputerze kodującym.

Tematy pokrewne

  • Kodowanie plików i zdarzeń na żywo
  • Kodowanie pliku
  • Kodowanie wszystkich plików w folderze


Kodowanie wsadowe

Używając kodowania wsadowego, można szybko zakodować wiele plików, zamiast wykonywać osobne polecenie dla każdego pliku. W przypadku kodowania wsadowego tworzony jest plik wsadowy lub plik tekstowy z rozszerzeniem .bat, który zawiera wszystkie używane polecenia kodowania. Te polecenia mogą uwzględniać nazwy plików wejściowych i wyjściowych, używane profile i inne opcje wiersza polecenia, które mają zostać zastosowane. Nie ma ograniczenia liczby poleceń, które można wstawić w pliku wsadowym, a ponieważ jest to plik tekstowy, jego edycja jest łatwa.

Gdy plik wsadowy jest gotowy, należy przejść do folderu, w którym zainstalowany jest program Skrypt kodowania Windows Media, a następnie wpisać nazwę pliku wsadowego. Na przykład Mójplikwsadowy.bat.

Polecenia w poniższym przykładzie to tylko niektóre polecenia, które można znaleźć w pliku wsadowym. Przykład przedstawia sposób użycia poleceń dla źródłowego filmu o parametrach 640 × 480, 24 k/s, który został przed zakodowaniem poddany działaniu funkcji telecine z szybkością 30 k/s, a następnie przekonwertowany do prędkości 24 k/s za pomocą filtru inverse telecine. Pierwsze dwa polecenia informują narzędzie, że ma być użyte kodowanie o zmiennej szybkości transmisji bitów w oparciu o jakość (-v_mode 2) do zakodowania źródła z ustawieniami jakości odpowiednio 95 i 97. Ostatnie dwa polecenia informują narzędzie, że ma być użyte kodowanie dwuprzebiegowe o stałej szybkości transmisji bitów (-v_mode 1) do zakodowania źródła z szybkością odpowiednio 1 megabita na sekundę (Mb/s) i 500 kilobitów na sekundę (Kb/s).

cscript.exe wmcmd.vbs -input C:\Moje-klipy\Mójfilm.avi -output C:\Moje-klipy-zakodowane\Mójfilm-640x480-vbr095.wmv -v_mode 2 -v_quality 95 -v_keydist 30 -v_preproc 5
cscript.exe wmcmd.vbs -input C:\Moje-klipy\Mójfilm.avi -output C:\Moje-klipy-zakodowane\Mójfilm-320x240-vbr097.wmv -v_mode 2 -v_quality 97 -v_keydist 30 -v_preproc 5 -v_width 320 -v_height 240
cscript.exe wmcmd.vbs -input C:\Moje-klipy\Mójfilm.avi -output C:\Moje-klipy-zakodowane\Mójfilm-640x480-cbr2.wmv -v_mode 1 -v_bitrate 1000000 -v_keydist 30 -v_buffer 10000 -v_quality 100 -v_preproc 5
cscript.exe wmcmd.vbs -input C:\Moje-klipy\Mójfilm.avi -output C:\Moje-klipy-zakodowane\Mójfilm-320x240-cbr2.wmv -v_mode 1 -v_bitrate 500000 -v_keydist 30 -v_buffer 10000 -v_quality 100 -v_preproc 5 -v_width 320 -v_height 240

  • Kodowanie plików i zdarzeń na żywo


Korzystanie z profili

Profil to zbiór opcji wiersza polecenia dopasowanych do typu kodowanej zawartości, prędkości połączenia, planowanych odbiorców i żądanej jakości obrazu wyjściowego. Jeśli dla sesji nie zostanie określony profil, zostaną użyte następujące domyślne opcje:

  • Kodery-dekodery Windows Media Audio 9 i Windows Media Video 9
  • Kodowanie jednoprzebiegowe CBR
  • Szybkość klatek równa 30 k/s
  • Wysokość i szerokość zgodna ze źródłem wejściowym
  • Audio stereo
  • Częstotliwość próbkowania równa 44 100 Hz
  • Bufor o rozmiarze 5 000 milisekund
  • Ustawienie gładkości równe 75
  • Odległość klatek kluczowych równa 10 sekund
  • Szybkości przesyłania bitów audio i wideo odpowiednio 64 i 250 Kb/s

Można zastąpić dowolne domyślne opcje, dołączając inne opcje wiersza polecenia do polecenia.

Można również utworzyć profil niestandardowy, określając w poleceniu każdą opcję, która ma zostać użyta. Do polecenia można dołączyć opcję -saveprofile, aby zapisać profil w celu ponownego jego użycia. Następnie, aby ponownie użyć profilu lub zakodować zawartość za pomocą profilu Windows Media Encoder, można użyć opcji -loadprofile. Pliki profili mają rozszerzenie prx.

Program Skrypt kodowania Windows Media zawiera szereg zdefiniowanych wstępnie profili, których można użyć w sesji (za pomocą opcji -profile).

Tematy pokrewne

  • Skrypt kodowania Windows Media
  • Określanie profilu dla sesji
  • Profile audio i wideo
  • Profile tylko dla audio
  • Profile tylko dla wideo
  • Korzystanie z plików konfiguracyjnych
  • Korzystanie z opcji wiersza polecenia


Określanie profilu dla sesji

transparent programu Windows Media Encoder

Aby określić profil dla sesji

  1. Otwórz okno wiersza polecenia.
  2. W wierszu polecenia wpisz ścieżkę folderu, w którym znajduje się skrypt Wmcmd.vbs. Na przykład wpisz:
    cd \Program Files\Windows Media Components\Encoder
  3. Wykonaj jedną z następujących czynności:
    • Aby określić profil dołączony do Skryptu kodowania Windows Media, wpisz poniższe polecenie, a następnie naciśnij klawisz ENTER:
      cscript.exe wmcmd.vbs –input stacja dysków:\Ścieżka\Nazwa_pliku_wejściowego -output stacja dysków:\Ścieżka\Nazwa_pliku_wyjściowego -profile numer_profilu

      Na przykład:

      cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mójplik.avi –output C:\Moje-klipy-zakodowane\Mójplik.wmv –profile av100
    • Aby określić profil programu Windows Media Encoder lub utworzony profil niestandardowy, wpisz poniższe polecenie, a następnie naciśnij klawisz ENTER:
      cscript.exe wmcmd.vbs –input stacja dysków:\Ścieżka\Nazwa_pliku_wejściowego -output stacja dysków:\Ścieżka\Nazwa_pliku_wyjściowego -loadprofile stacja dysków:\Ścieżka\Nazwa_pliku_profilu

      Na przykład:

      cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mójplik.avi -output C:\Moje-klipy-zakodowane\Mójplik.wmv -loadprofile C:\Moje-profile\500kbps_peakVBR.prx

  • Korzystanie z profili


Profile audio i wideo

Skrypt Windows Media Encoding Script zawiera 14 profili systemowych do kodowania zawartości zawierającej audio i wideo. Poniższa tabela zawiera krótki opis każdego profilu.

Nazwa profilu | Szybkość transmisji bitów (Kb/s) | Opis
av20 | 20 | Modem 28 Kb/s
av32 | 32 | Modem 56 Kb/s
av100 | 100 | Sieć LAN (Local area network)
av225 | 225 | Sieć LAN
av350 | 350 | Sieć LAN i cyfrowa linia abonencka (DSL)
av450 | 450 | Sieć LAN i DSL
av700 | 700 | Jakość zbliżona do telewizyjnej – system NTSC (National Television Standards Committee)
av1400 | 1 400 | Jakość zbliżona do telewizyjnej – system NTSC
av350pal | 350 | Komunikacja szerokopasmowa – system PAL (Phase Alternating Line)
av700pal | 700 | Jakość zbliżona do telewizyjnej – system PAL
av100_2p | 100 | Sieć LAN i dwuprzebiegowa stała szybkość transmisji bitów (CBR)
av350_2p | 350 | Sieć LAN, DSL i dwuprzebiegowe CBR
av600vbr | 600 | Film, CBR (audio) i szczytowe różne prędkości transmisji bitów (VBR) (wideo)
avq97vbr | -- | Film, CBR (audio) i VBR (wideo) w oparciu o jakość

  • Korzystanie z profili


av20

  • Nazwa: av20 (Profile_AudioVideo_Modem_28K)
  • Koder-dekoder audio: Windows Media Audio 9
  • Szybkość transmisji bitów audio: 5 000 b/s
  • Częstotliwość próbkowania: 8 000 Hz
  • Liczba kanałów: 1
  • Koder-dekoder wideo: Windows Media Video 9
  • Tryb kodowania: Jednoprzebiegowe CBR
  • Optymalizacja wideo: Brak
  • Szybkość transmisji bitów wideo: 15 000 b/s
  • Szerokość klatki: 160 pikseli
  • Wysokość klatki: 120 pikseli
  • Szybkość klatek: 15 k/s
  • Bufor: 5 000 ms
  • Płynność/jakość: 75
  • Odległość klatek kluczowych: 10 s
  • Całkowita szybkość transmisji bitów: 20 000 b/s

  • Profile audio i wideo


av32

  • Nazwa: av32 (Profile_AudioVideo_Modem_56K)
  • Koder-dekoder audio: Windows Media Audio 9
  • Szybkość transmisji bitów audio: 10 168 b/s
  • Częstotliwość próbkowania: 11 025 Hz
  • Liczba kanałów: 1
  • Koder-dekoder wideo: Windows Media Video 9
  • Tryb kodowania: Jednoprzebiegowe CBR
  • Optymalizacja wideo: Brak
  • Szybkość transmisji bitów wideo: 22 000 b/s
  • Szerokość klatki: 176 pikseli
  • Wysokość klatki: 144 pikseli
  • Szybkość klatek: 15 k/s
  • Bufor: 5 000 ms
  • Płynność/jakość: 75
  • Odległość klatek kluczowych: 10 s
  • Całkowita szybkość transmisji bitów: 32 168 b/s

  • Profile audio i wideo


av100

  • Nazwa: av100 (Profile_AudioVideo_LAN_100K)
  • Koder-dekoder audio: Windows Media Audio 9
  • Szybkość transmisji bitów audio: 16 000 b/s
  • Częstotliwość próbkowania: 16 000 Hz
  • Liczba kanałów: 1
  • Koder-dekoder wideo: Windows Media Video 9
  • Tryb kodowania: Jednoprzebiegowe CBR
  • Optymalizacja wideo: Brak
  • Szybkość transmisji bitów wideo: 84 000 b/s
  • Szerokość klatki: 320 pikseli
  • Wysokość klatki: 240 pikseli
  • Szybkość klatek: 15 k/s
  • Bufor: 5 000 ms
  • Płynność/jakość: 75
  • Odległość klatek kluczowych: 10 s
  • Całkowita szybkość transmisji bitów: 100 000 b/s

  • Profile audio i wideo


av225

  • Nazwa: av225 (Profile_AudioVideo_LAN_256K)
  • Koder-dekoder audio: Windows Media Audio 9
  • Szybkość transmisji bitów audio: 40 000 b/s
  • Częstotliwość próbkowania: 32 000 Hz
  • Liczba kanałów: 2
  • Koder-dekoder wideo: Windows Media Video 9
  • Tryb kodowania: Jednoprzebiegowe CBR
  • Optymalizacja wideo: Brak
  • Szybkość transmisji bitów wideo: 185 000 b/s
  • Szerokość klatki: 320 pikseli
  • Wysokość klatki: 240 pikseli
  • Szybkość klatek: 30 k/s
  • Bufor: 5 000 ms
  • Płynność/jakość: 75
  • Odległość klatek kluczowych: 10 s
  • Całkowita szybkość transmisji bitów: 225 000 b/s

  • Profile audio i wideo


av350

  • Nazwa: av350 (Profile_AudioVideo_LANDSL_384K)
  • Koder-dekoder audio: Windows Media Audio 9
  • Szybkość transmisji bitów audio: 48 000 b/s
  • Częstotliwość próbkowania: 32 000 Hz
  • Liczba kanałów: 2
  • Koder-dekoder wideo: Windows Media Video 9
  • Tryb kodowania: Jednoprzebiegowe CBR
  • Optymalizacja wideo: Brak
  • Szybkość transmisji bitów wideo: 302 000 b/s
  • Szerokość klatki : 320 pikseli
  • Wysokość klatki: 240 pikseli
  • Szybkość klatek: 30 k/s
  • Bufor: 5 000 ms
  • Płynność/jakość: 75
  • Odległość klatek kluczowych: 10 s
  • Całkowita szybkość transmisji bitów: 350 000 b/s

  • Profile audio i wideo


av450

  • Nazwa: av450 (Profile_AudioVideo_LANDSL_768K)
  • Koder-dekoder audio: Windows Media Audio 9
  • Szybkość transmisji bitów audio: 64 040 b/s
  • Częstotliwość próbkowania: 44 100 Hz
  • Liczba kanałów: 2
  • Koder-dekoder wideo: Windows Media Video 9
  • Tryb kodowania: Jednoprzebiegowe CBR
  • Optymalizacja wideo: Brak
  • Szybkość transmisji bitów wideo: 386 000 b/s
  • Szerokość klatki: 320 pikseli
  • Wysokość klatki: 240 pikseli
  • Szybkość klatek: 30 k/s
  • Bufor: 5 000 ms
  • Płynność/jakość: 75
  • Odległość klatek kluczowych: 10 s
  • Całkowita szybkość transmisji bitów: 450 040 b/s

  • Profile audio i wideo


av700

  • Nazwa: av700 (Profile_AudioVideo_NearBroadCast_700K)
  • Koder-dekoder audio: Windows Media Audio 9
  • Szybkość transmisji bitów audio: 64 040 b/s
  • Częstotliwość próbkowania: 44 100 Hz
  • Liczba kanałów: 2
  • Koder-dekoder wideo: Windows Media Video 9
  • Tryb kodowania: Jednoprzebiegowe CBR
  • Optymalizacja wideo: Brak
  • Szybkość transmisji bitów wideo: 636 000 b/s
  • Szerokość klatki: 320 pikseli
  • Wysokość klatki: 240 pikseli
  • Szybkość klatek: 30 k/s
  • Bufor: 5 000 ms
  • Płynność/jakość: 75
  • Odległość klatek kluczowych: 10 s
  • Całkowita szybkość transmisji bitów: 700 040 b/s

  • Profile audio i wideo


av1400

  • Nazwa: av1400 (Profile_AudioVideo_NearBroadCast_1400K)
  • Koder-dekoder audio: Windows Media Audio 9
  • Szybkość transmisji bitów audio: 128 040 b/s
  • Częstotliwość próbkowania: 44 100 Hz
  • Liczba kanałów: 2
  • Koder-dekoder wideo: Windows Media Video 9
  • Tryb kodowania: Jednoprzebiegowe CBR
  • Optymalizacja wideo: Brak
  • Szybkość transmisji bitów wideo: 127 2000 b/s
  • Szerokość klatki: 320 pikseli
  • Wysokość klatki: 240 pikseli
  • Szybkość klatek: 30 k/s
  • Bufor: 5000
  • Płynność/jakość: 75
  • Odległość klatek kluczowych: 10 s
  • Całkowita szybkość transmisji bitów: 1 400 040 b/s

  • Profile audio i wideo


av350pal

  • Nazwa: av350pal (Profile_AudioVideo_Broadband_PAL_384K)
  • Koder-dekoder audio: Windows Media Audio 9
  • Szybkość transmisji bitów audio: 48 000 b/s
  • Częstotliwość próbkowania: 32 000 Hz
  • Liczba kanałów: 2
  • Koder-dekoder wideo: Windows Media Video 9
  • Tryb kodowania: Jednoprzebiegowe CBR
  • Optymalizacja wideo: Brak
  • Szybkość transmisji bitów wideo: 302 000 b/s
  • Szerokość klatki: 384 piksele
  • Wysokość klatki: 288 pikseli
  • Szybkość klatek: 25 k/s
  • Bufor: 5 000 ms
  • Płynność/jakość: 75
  • Odległość klatek kluczowych: 10 s
  • Całkowita szybkość transmisji bitów: 350 000 b/s

  • Profile audio i wideo


av700pal

  • Nazwa: av700pal (Profile_AudioVideo_NearBroadCast_PAL_700K)
  • Koder-dekoder audio: Windows Media Audio 9
  • Szybkość transmisji bitów audio: 64 040 b/s
  • Częstotliwość próbkowania: 44 100 Hz
  • Liczba kanałów: 2
  • Koder-dekoder wideo: Windows Media Video 9
  • Tryb kodowania: Jednoprzebiegowe CBR
  • Optymalizacja wideo: Brak
  • Szybkość transmisji bitów wideo: 636 000 b/s
  • Szerokość klatki: 384 piksele
  • Wysokość klatki: 288 pikseli
  • Szybkość klatek: 25 k/s
  • Bufor: 5 000 ms
  • Płynność/jakość: 75
  • Odległość klatek kluczowych: 10 s
  • Całkowita szybkość transmisji bitów: 700 040 b/s

  • Profile audio i wideo


av100_2p

  • Nazwa: av100_2p (Profile_AudioVideo_LAN_100K_2Pass)
  • Koder-dekoder audio: Windows Media Audio 9
  • Szybkość transmisji bitów audio: 16 000 b/s
  • Częstotliwość próbkowania: 16 000 Hz
  • Liczba kanałów: 1
  • Koder-dekoder wideo: Windows Media Video 9
  • Tryb kodowania: Dwuprzebiegowe CBR
  • Optymalizacja wideo: Brak
  • Szybkość transmisji bitów wideo: 84 000 b/s
  • Szerokość klatki: 320 piksele
  • Wysokość klatki: 240 pikseli
  • Szybkość klatek: 15 k/s
  • Bufor: 5 000 ms
  • Płynność/jakość: 75
  • Odległość klatek kluczowych: 10 s
  • Całkowita szybkość transmisji bitów: 100 000 b/s

  • Profile audio i wideo


av350_2p

  • Nazwa: av350_2p (Profile_AudioVideo_LANDSL_384K_2Pass)
  • Koder-dekoder audio: Windows Media Audio 9
  • Szybkość transmisji bitów audio: 48 000 b/s
  • Częstotliwość próbkowania: 32 000 Hz
  • Liczba kanałów: 2
  • Koder-dekoder wideo: Windows Media Video 9
  • Tryb kodowania: : Dwuprzebiegowe CBR
  • Optymalizacja wideo: Brak
  • Szybkość transmisji bitów wideo: 302 000 b/s
  • Szerokość klatki: 320 piksele
  • Wysokość klatki: 240 pikseli
  • Szybkość klatek: 30 k/s
  • Bufor: 5 000 ms
  • Płynność/jakość: 75
  • Odległość klatek kluczowych: 10 s
  • Całkowita szybkość transmisji bitów: 350 000 b/s

  • Profile audio i wideo


av600vbr

  • Nazwa: av600vbr (Profile_AudioVideo_FilmVBR_600K)
  • Koder-dekoder audio: Windows Media Audio 9
  • Szybkość transmisji bitów audio: 64 040 b/s
  • Częstotliwość próbkowania: 44 100 Hz
  • Liczba kanałów: 2
  • Koder-dekoder wideo: Windows Media Video 9
  • Tryb kodowania: Oparte na szczytowej szybkości transmisji bitów VBR (wideo) i CBR (audio)
  • Optymalizacja wideo: Inverse telecine
  • Szybkość transmisji bitów wideo: 536 000 b/s
  • Szczytowa szybkość transmisji bitów wideo: 804 000 b/s
  • Szerokość klatki: 320 pikseli
  • Wysokość klatki: 240 pikseli
  • Szybkość klatek: 24 k/s
  • Szczytowy bufor: 5 000 ms
  • Odległość klatek kluczowych: 10 s
  • Całkowita szybkość transmisji bitów: 600 040 b/s

  • Profile audio i wideo


avq97vbr

  • Nazwa: avq97vbr (Profile_AudioVideo_FilmVBR_Quality97)
  • Koder-dekoder audio: Windows Media Audio 9
  • Szybkość transmisji bitów audio: 64 040 b/s
  • Częstotliwość próbkowania: 44 100 Hz
  • Liczba kanałów: 2
  • Koder-dekoder wideo: Windows Media Video 9
  • Tryb kodowania: Oparte na jakości VBR (wideo) i CBR (audio)
  • Optymalizacja wideo: Inverse telecine
  • Szerokość klatki: 320 pikseli
  • Wysokość klatki: 240 pikseli
  • Szybkość klatek: 24 k/s
  • Jakość: 97
  • Odległość klatek kluczowych: 10 s

  • Profile audio i wideo


Profile tylko dla audio

Skrypt Windows Media Encoding Script zawiera siedem profili systemowych do kodowania zawartości zawierającej audio, ale nie wideo. Poniższa tabela zawiera krótki opis każdego profilu.

Nazwa profilu | Szybkość transmisji bitów (Kb/s) | Opis
a20_1 | 20 | Radio FM mono
a20_2 | 20 | Radio FM stereo
a32 | 32 | Modem 56 Kb/s
a48 | 48 | Jakość zbliżona do CD
a64 | 64 | Jakość CD
a96 | 96 | Audiofilska jakość CD
a128 | 128 | Audiofilska jakość CD

  • Korzystanie z profili


a20_1

  • Nazwa: a20_1 (Profile_AudioOnly_FMRadioMono_28K)
  • Koder-dekoder: Windows Media Audio 9
  • Szybkość transmisji bitów audio: 20 008 b/s
  • Częstotliwość próbkowania: 22 050 Hz
  • Liczba kanałów: 1
  • Całkowita szybkość transmisji bitów: 20 008 b/s

  • Profile tylko dla audio


a20_2

  • Nazwa: a20_2 (Profile_AudioOnly_FMRadioStereo_28K)
  • Koder-dekoder audio: Windows Media Audio 9
  • Szybkość transmisji bitów audio: 20 008 b/s
  • Częstotliwość próbkowania: 22 050 Hz
  • Liczba kanałów: 2
  • Całkowita szybkość transmisji bitów: 20 008 b/s

  • Profile tylko dla audio


a32

  • Nazwa: a32 (Profile_AudioOnly_Modem_56K)
  • Koder-dekoder audio: Windows Media Audio 9
  • Szybkość transmisji bitów audio: 32 000 b/s
  • Częstotliwość próbkowania: 32 000 Hz
  • Liczba kanałów: 2
  • Całkowita szybkość transmisji bitów: 32 000 b/s

  • Profile tylko dla audio


a48

  • Nazwa: a48 (Profile_AudioOnly_NearCDQuality_48K)
  • Koder-dekoder audio: Windows Media Audio 9
  • Szybkość transmisji bitów audio: 48 024 b/s
  • Częstotliwość próbkowania: 32 000 Hz
  • Liczba kanałów: 2
  • Całkowita szybkość transmisji bitów: 48 024 b/s

  • Profile tylko dla audio


a64

  • Nazwa: a64 (Profile_AudioOnly_CDQuality_64K)
  • Koder-dekoder audio: Windows Media Audio 9
  • Szybkość transmisji bitów audio: 64 016 b/s
  • Częstotliwość próbkowania: 44 100 Hz
  • Liczba kanałów: 2
  • Całkowita szybkość transmisji bitów: 64 016 b/s

  • Profile tylko dla audio


a96

  • Nazwa: a96 (Profile_AudioOnly_CDAudiophileQuality_96K)
  • Koder-dekoder audio: Windows Media Audio 9
  • Szybkość transmisji bitów audio: 96 024 b/s
  • Częstotliwość próbkowania: 44 100 Hz
  • Liczba kanałów: 2
  • Całkowita szybkość transmisji bitów: 96 024 b/s

  • Profile tylko dla audio


a128

  • Nazwa: a128 (Profile_AudioOnly_CDAudiophileQuality_128K)
  • Koder-dekoder audio: Windows Media Audio 9
  • Szybkość transmisji bitów audio: 128 016 b/s
  • Częstotliwość próbkowania: 44 100 Hz
  • Liczba kanałów: 2
  • Całkowita szybkość transmisji bitów: 128 016 b/s

Tematy pokrewne

  • Profile tylko dla audio
© 2000-2002 Microsoft Corporation. Wszelkie prawa zastrzeżone


Profile tylko dla wideo

Program Skrypt kodowania Windows Media zawiera dwa profile systemowe do kodowania zawartości, która zawiera wideo, ale nie audio. Poniższa tabela zawiera krótki opis każdego profilu.

Nazwa profilu | Szybkość transmisji bitów (Kb/s) | Opis
v20 | 20 | Tylko wideo, modem o prędkości 28 Kb/s
v32 | 32 | Tylko wideo, modem o prędkości 56 Kb/s

  • Korzystanie z profili


v20

  • Nazwa: v20 (Profile_VideoOnly_Modem_28K)
  • Koder-dekoder wideo: Windows Media Video 9
  • Tryb kodowania: Jednoprzebiegowe CBR
  • Optymalizacja wideo: Brak
  • Szybkość transmisji bitów wideo: 20 000 b/s
  • Szerokość klatki: 176 pikseli
  • Wysokość klatki: 144 piksele
  • Szybkość klatek: 15 k/s
  • Bufor: 5 000 ms
  • Płynność/jakość: 75
  • Odległość klatek kluczowych: 10 s.
  • Całkowita szybkość transmisji bitów: 20 000 b/s

  • Profile tylko dla wideo


v32

  • Nazwa: v32 (Profile_VideoOnly_Modem_56K)
  • Koder-dekoder wideo: Windows Media Video 9
  • Tryb kodowania: Jednoprzebiegowe CBR
  • Optymalizacja wideo: Brak
  • Szybkość transmisji bitów: 32 000 b/s
  • Szerokość klatki: 240 pikseli
  • Wysokość klatka: 176 pikseli
  • Szybkość klatek: 15 k/s
  • Bufor: 5 000 ms
  • Płynność/jakość: 75
  • Odległość klatek kluczowych: 10 s
  • Całkowita szybkość transmisji bitów: 32 000 b/s

  • Profile tylko dla wideo


Zaawansowane techniki kodowania

Korzystając ze Skryptu kodowania Windows Media, użytkownik może używać wielu opcji dostrajania ustawień kodowania. W tej części opisano opcje i sposoby ich użycia.

Tematy pokrewne

  • Skrypt kodowania Windows Media
  • Optymalizowanie audio i wideo
  • Korzystanie z kodowania CBR lub VBR
  • Pobieranie źródła z plików wielokanałowego audio
  • Korzystanie z plików konfiguracyjnych
  • Korzystanie z opcji wiersza polecenia


Optymalizowanie wideo i audio

W skład programu Skrypt kodowania Windows Media wchodzą filtry, za pomocą których można podnieść jakość zawartości poddanej efektowi telecine i zawartości z przeplotem w celu odtwarzania jej na ekranach skanowania progresywnego lub zachować przeplot w zawartości w celu odtwarzania jej na urządzeniach odtwarzających z przeplotem. Domyślnie filtry nie są stosowane (opcja -v_preproc 0). Polecenie braku filtru należy stosować w przypadku zawartości, która jest już w formacie skanowania stopniowego i która zostanie poddana renderowaniu na ekranie skanowania progresywnego.

Jeżeli zawartość audio składa się głównie z głosu i niewielkiej liczby utworów muzycznych, można skorzystać z opcji -a_content i -a_contentedl w celu zoptymalizowania zawartości pod kątem głosu.

Tematy pokrewne

  • Zaawansowane techniki kodowania
  • Filtry usuwania przeplotu
  • Filtry inverse telecine
  • Filtry przeplotu
  • Optymalizowanie audio dla głosu


Filtry usuwania przeplotu

Filtr usuwania przeplotu konwertuje wideo z przeplotem na format skanowania progresywnego. Poniższa tabela opisuje polecenia dostępne podczas stosowania filtru usuwania przeplotu z wideo.

Polecenie | Opis
-v_preproc 1 | Zachowuje rozmiar wideo źródłowego. Na przykład wideo o wymiarach 640×480 pikseli o szybkości 30 klatek na sekundę jest kodowane w wymiarach 640×480 pikseli i z szybkością 30 klatek na sekundę.
-v_preproc 2 | Wideo wyjściowe ma rozmiar równy połowie oryginalnego. Na przykład wideo o wymiarach 640×480 pikseli i szybkości 30 klatek na sekundę jest kodowane w wymiarach 320×240 i z szybkością 30 klatek na sekundę.
-v_preproc 3 | Wideo wyjściowe ma rozmiar równy połowie oryginalnego, a szybkość klatek jest podwajana. Na przykład wideo o wymiarach 640×480 pikseli i szybkości 30 klatek na sekundę jest kodowane w wymiarach 320×240 i z szybkością 60 klatek na sekundę.
-v_preproc 4 | Wideo wyjściowe ma rozmiar pionowy równy połowie oryginalnego, a szybkość klatek jest podwajana. Na przykład wideo o wymiarach 320×480 pikseli i szybkości 30 klatek na sekundę jest kodowane w wymiarach 320×240 i z szybkością 60 klatek na sekundę.

Tematy pokrewne

  • Optymalizowanie wideo i audio
  • Filtry inverse telecine
  • Filtry przeplotu
  • Stosowanie filtru do zawartości


Filtry inverse telecine

Filtr inverse telecine konwertuje wideo z 30 k/s do 24 k/s. Poniższa tabela zawiera opis poleceń dostępnych dla użytkownika po zastosowaniu filtrów inverse telecine w wideo.

Polecenie | Opis
-v_preproc 5 | Należy użyć, jeśli zawartość ma niespójności lub nie ma pewności, od której klatki zaczyna się zawartość.
-v_preproc 6 | Należy użyć, jeśli pierwsze pole w klatce jest pierwszym (nieparzystym) polem we wzorze AA telecine.
-v_preproc 7 | Należy użyć, jeśli pierwsze pole w klatce jest pierwszym (nieparzystym) polem we wzorze BB telecine.
-v_preproc 8 | Należy użyć, jeśli pierwsze pole w klatce jest pierwszym (nieparzystym) polem we wzorze BC telecine.
-v_preproc 9 | Należy użyć, jeśli pierwsze pole w klatce jest pierwszym (nieparzystym) polem we wzorze CD telecine.
-v_preproc 10 | Należy użyć, jeśli pierwsze pole w klatce jest pierwszym (nieparzystym) polem we wzorze DD telecine.
-v_preproc 11 | Należy użyć, jeśli pierwsze pole w klatce jest ostatnim (parzystym) polem we wzorze AA telecine.
-v_preproc 12 | Należy użyć, jeśli pierwsze pole w klatce jest ostatnim (parzystym) polem we wzorze BB telecine.
-v_preproc 13 | Należy użyć, jeśli pierwsze pole w klatce jest ostatnim (parzystym) polem we wzorze BC telecine.
-v_preproc 14 | Należy użyć, jeśli pierwsze pole w klatce jest ostatnim (parzystym) polem we wzorze CD telecine.
-v_preproc 15 | Należy użyć, jeśli pierwsze pole w klatce jest ostatnim (parzystym) polem we wzorze DD telecine.

Tematy pokrewne

  • Optymalizowanie wideo i audio
  • Filtry usuwania przeplotu
  • Filtry przeplotu
  • Stosowanie filtru do zawartości


Filtry przeplotu

Filtr przeplotu zachowuje przeplot w wideo źródłowym. Poniższa tabela zawiera opis poleceń dostępnych dla użytkownika podczas stosowania filtru przeplotu dla wideo.

Polecenie | Opis
-v_preproc 16 | Zachowuje przeplot w wideo źródłowym.
-v_preproc 17 | Zachowuje przeplot w wideo źródłowym. Należy go użyć, jeśli pierwsze kodowane pole to pole górne (nieparzyste).
-v_preproc 18 | Zachowuje przeplot w wideo źródłowym. Należy go użyć, jeśli pierwsze kodowane pole to pole dolne (parzyste).

Tematy pokrewne

  • Optymalizowanie wideo i audio
  • Filtry usuwania przeplotu
  • Filtry inverse telecine
  • Stosowanie filtru do zawartości


Stosowanie filtru do zawartości

transparent programu Windows Media Encoder

Aby zastosować filtr do zawartości

  1. Otwórz okno wiersza polecenia.
  2. W wierszu polecenia wpisz ścieżkę do folderu, w którym znajduje się plik Wmcmd.vbs. Na przykład wpisz
    cd \Program Files\Windows Media Components\Encoder
  3. Wpisz następujące polecenie, a następnie naciśnij klawisz ENTER:
    cscript.exe wmcmd.vbs –input stacja dysków:\Ścieżka\Nazwa_pliku_wejściowego -output stacja dysków:\Ścieżka\Nazwa_pliku_wyjściowego -v_preproc filtr

    Na przykład:

    cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mójplik.avi –output C:\Moje-zakodowane-klipy\Mójplik.wmv -v_preproc 3

  • Optymalizowanie wideo i audio


Optymalizowanie audio dla głosu

Jeśli źródłem jest sygnał audio składający się całkowicie lub głównie z głosu, można użyć opcji -a_content i kodera-dekodera Windows Media Audio 9 Voice w celu optymalizacji kodowania głosu. Można zoptymalizować zachowanie kodera-dekodera przez zidentyfikowanie, czy zawartość jest tylko głosem (-a_content 1) lub czy zawiera niewiele muzyki (a_content 2). Jeśli audio jest połączeniem głosu i muzyki, podczas kodowania koder-dekoder automatycznie użyje odpowiedniego algorytmu optymalizującego kodowanie zawartości (głos lub muzyka). Można również utworzyć plik definicji optymalizacji (-a_contentedl), który jest plikiem tekstowym identyfikującym miejsca w pliku, w których muzyka się zaczyna i kończy. Nieokreślone części pliku są traktowane jako głos. W poniższym przykładzie zawartość audio składa się tylko z głosu.

cscript.exe wmcmd.vbs –input C:\Moje-przemówienia\Mojeprzemówienie.wav –output C:\Moje-przemówienia-zakodowane\Mojeprzemówienie.wma -a_codec WMSP9 -a_content 1

W poniższym przykładnie zawartość audio jest mieszanką głosu i muzyki. Utworzono także plik definicji optymalizacji.

cscript.exe wmcmd.vbs –input C:\Moje-przemówienia\Mojeprzemówienie.wav –output C:\Moje-przemówienia-zakodowane\Mojeprzemówienie.wma -a_codec WMSP9 -a_content 2 -a_contentedl c:\Moje-przemówienia\moja_lista_edl_zawartości.txt

Tematy pokrewne

  • Optymalizowanie wideo i audio
  • Tworzenie pliku definicji optymalizacji audio


Tworzenie pliku definicji optymalizacji audio

transparent programu Windows Media Encoder

Aby utworzyć plik definicji optymalizacji audio

  1. Za pomocą edytora tekstu, na przykład Notatnika, utwórz plik tekstowy.
  2. Wpisz numer wersji i liczbę segmentów muzycznych zawartych w pliku.

    Numer wersji powinien zawsze mieć wartość 1.

  3. Wpisz czasy rozpoczęcia i zakończenia każdego segmentu (w milisekundach), oddzielając każdy z tych czasów przecinkiem.

    Na przykład wpisanie wartości 1, 3, 0, 10000, 50000, 80000, 150000 i 200000 wskazuje, że istnieją trzy segmenty muzyczne; koder-dekoder przełączy się do trybu muzyki pomiędzy 0 a 10 sekundą, pomiędzy 50 a 80 sekundą oraz pomiędzy 150 a 200 sekundą.

  4. Zakoduj plik tekstowy w formacie Unicode.

    Jeżeli plik tworzony jest za pomocą Notatnika, w celu zapisania go w formacie Unicode należy wybrać polecenie Zapisz z menu Plik, a następnie w polu Kodowanie kliknąć pozycję Unicode.

  • Optymalizowanie audio dla głosu


Korzystanie z kodowania CBR lub VBR

Zawartość audio lub wideo można kodować ze stałą szybkością transmisji bitów (CBR) lub ze zmienną szybkością transmisji bitów (VBR). Kodowania CBR należy użyć, jeśli zawartość ma być przesyłana strumieniowo. Kodowania VBR należy użyć, jeśli planowane jest dystrybuowanie zawartości do pobierania i odtwarzania lokalnie lub za pomocą urządzenia, które ma ograniczoną prędkość odczytu, takiego jak odtwarzacz CD lub DVD.

  • Kodowanie CBR. Dzięki tej opcji zmiany szybkości transmisji bitów są ograniczone przez rozmiar buforu i zmiany jakości obrazu, co zapewnia, że nie wystąpi przepełnienie lub niedopełnienie buforu. Kodowanie CBR może być jedno- lub dwuprzebiegowe.
  • Kodowanie VBR w oparciu o jakość. Dzięki tej opcji zawartość jest kodowana z określoną jakością (od 0 do 100). Podczas kodowania szybkość transmisji bitów zmienia się w celu zapewnienia określonej jakości. Tej opcji należy używać, gdy nie jest ważna szybkość transmisji bitów, a ważna jest jakość materiału wyjściowego. Ta opcja wykorzystuje kodowanie jednoprzebiegowe.
  • Kodowanie VBR w oparciu o szybkość transmisji bitów. Dzięki tej opcji zawartość jest kodowana ze średnią szybkością transmisji bitów. W dowolnym punkcie szybkość transmisji bitów może przekraczać średnią szybkość transmisji bitów, ale ogólna szybkość transmisji bitów jest zgodna z średnią szybkością transmisji bitów. W tym trybie nie są gubione klatki. Ta opcja wykorzystuje kodowanie dwuprzebiegowe.
  • Kodowanie VBR oparte na szczytowej szybkości transmisji bitów. Ta opcja jest podobna to opcji kodowania VBR opartego na szybkości transmisji bitów, z tym że zmiany szybkości transmisji bitów nie przekraczają szczytowej szybkości transmisji bitów. Tej opcji należy użyć, gdy zawartość będzie odtwarzana za pomocą urządzenia o ograniczonej szybkości odczytu, takiego jak odtwarzacz CD lub DVD. Ta opcja wykorzystuje kodowanie dwuprzebiegowe.

obrazek „Uwaga” Uwaga

  • Jeśli zawartość jest kodowana przy użyciu profilu, w którym nie określono kodowania CBR lub VBR, lub jeśli skonfigurowano niestandardową sesję kodowania i nie określono kodowania CBR lub VBR, to domyślnie używane jest jednoprzebiegowe kodowanie CBR.

Tematy pokrewne

  • Zaawansowane techniki kodowania
  • Implementowanie trybu kodowania CBR lub VBR


Implementowanie trybu kodowania CBR lub VBR

Podczas implementowania trybu kodowania CBR lub VBR jedyny wymagany parametr to opcja -v_mode lub -a_mode dla wyboru trybu. Jednakże każdy tryb ma parametry opcjonalne, które można określić. Jeśli parametr nie zostanie określony, używane są wartości domyślne.

Poniższa tabela zawiera podsumowanie opcji wiersza polecenia, których można użyć podczas implementacji trybu kodowania CBR lub VBR dla zawartości wideo.

Tryb | Parametry opcjonalne
Jednoprzebiegowe CBR (-v_mode 0) | -v_bitrate i -v_buffer
Dwuprzebiegowe CBR (-v_mode 1) | -v_bitrate i -v_buffer
VBR w oparciu o jakość (jednoprzebiegowe, -v_mode 2) | -v_quality (wartość domyślna to 95)
VBR w oparciu o szybkość transmisji bitów (dwuprzebiegowe, -v_mode 3) | -v_bitrate
VBR w oparciu o szczytową szybkość transmisji bitów (dwuprzebiegowe, -v_mode 4) | -v_bitrate, -v_peakbitrate i -v_peakbuffer

Poniższa tabela zawiera podsumowanie opcji wiersza polecenia, których można użyć podczas implementacji trybu CBR lub VBR dla zawartości audio.

Tryb | Parametry opcjonalne
Jednoprzebiegowe CBR (-a_mode 0) | -a_setting
Dwuprzebiegowe CBR (-a_mode 1) | -a_setting
VBR w oparciu o jakość (jednoprzebiegowe, -a_mode 2) | -a_setting (więcej informacji zawierają kolejne paragrafy)
VBR w oparciu o szybkość transmisji bitów (dwuprzebiegowe, -a_mode 3) | -a_setting
VBR w oparciu o szczytową szybkość transmisji bitów (dwuprzebiegowe, -a_mode 4) | -a_setting, -a_peakbitrate i -a_peakbuffer

W sesji można wykorzystywać różne tryby kodowania. Można na przykład używać dwuprzebiegowego kodowania CBR dla audio oraz kodowania VBR opartego o jakość dla wideo.

Korzystanie z kodowania VBR opartego o jakość

Podczas korzystania z kodowania VBR opartego o jakość do kodowania audio, można użyć parametru -a_setting do przedstawienia jakości docelowej z wykorzystaniem formatu Qwartość_częstotliwośćpróbkowania_kanał. Domyślną wartością jest Q75_44_2, chyba że zostanie także określony koder-dekoder Windows Media Audio 9 Professional, w przypadku którego domyślną wartością jest Q75_44_2_24. Na przykład:

cscript.exe wmcmd.vbs –input C:\Moje-piosenki\Piosenka1.wav –output C:\Moje-piosenki-zakodowane\Piosenka1.wma -a_codec WMA9PRO -a_mode 2 –a_setting Q98_48_2_24

Możliwe jest także korzystanie z kodera-dekodera Windows Media Audio 9 Lossless, który wymaga kodowania VBR opartego o jakość przy ustawieniu jakości 100. Wartość domyślna parametru -a_setting to Q100_44_2_16. Poniższy przykład przedstawia sposób tworzenia polecenia określającego kompresję bezstratną przy częstotliwości próbkowania 48 kHz, dwóch kanałach i 24-bitowym kodowaniu:

cscript.exe wmcmd.vbs –input C:\Moje-piosenki\Piosenka1.wav –output C:\Moje-piosenki-zakodowane\Piosenka1.wma -a_codec WMA9LSL -a_mode 2 –a_setting Q100_48_2_24

  • Korzystanie z kodowania CBR lub VBR


Pobieranie źródła z plików wielokanałowego audio

Za pomocą Skryptu kodowania Windows Media można kodować wielokanałowe audio, co oznacza, że można kodować dźwięk do odtwarzania przestrzennego 6- lub 8-kanałowego. Źródło zawartości musi być pojedynczym 6- lub 8-kanałowym plikiem w formacie WAVE_FORMAT_EXTENSIBLE, lub można użyć sześciu jednokanałowych plików .wav.

Gdy źródłem jest pojedynczy plik, należy skonfigurować polecenie identyfikujące plik jako wejście. Należy określić również koder-dekoder Windows Media Audio 9 Professional. Na przykład:

cscript.exe wmcmd.vbs –input C:\Moje-pliki_źródłowe\6_kanałów.wav –output C:\Moja_piosenka.wma -a_codec WMA9PRO -a_setting 640_48_6_24

-lub-

cscript.exe wmcmd.vbs –input C:\pliki_źródłowe\8_kanałów.wav -output C:\Moja_piosenka.wma -a_codec WMA9PRO -a_setting 384_48_8_24

Nie jest możliwe używanie jako źródła sześciu jednokanałowych plików .wav bezpośrednio w Skrypcie kodowania Windows Media. Zamiast tego można skonfigurować sesję wielokanałowego audio w programie Windows Media Encoder. Następnie można zapisać sesję i w poleceniu odwołać się do pliku sesji. Na przykład:

cscript.exe wmcmd.vbs –wme C:\Moja_sesja_wielokanałowa.wme

Gdy źródłem jest audio wielokanałowe, można też do polecenia dołączyć parametr -a_folddown6to2. Ten parametr określa, w jaki sposób sześć kanałów jest redukowanych do dwóch kanałów w celu odtwarzania na głośnikach stereo.

Użytkownik odtwarzający zawartość musi mieć system Microsoft Windows XP i odtwarzacz oparty na zestawie Windows Media Format 9 Series Software Development Kit (SDK); w przeciwnym przypadku dźwięk zostanie automatycznie zredukowany do dwóch kanałów dla głośników stereo.

  • Zaawansowane techniki kodowania


Korzystanie z plików konfiguracyjnych

Jeżeli użytkownik utworzy zestaw opcji wpisywanych w wierszu polecenia, z których chce korzystać w przyszłości, może zapisać je do pliku zwanego plikiem konfiguracyjnym. Plik konfiguracyjny jest plikiem tekstowym zawierającym nazwy i wartości opcji z wiersza polecenia, które mają być stosowane w sesji kodowania. Zamiast określać osobno każdą opcję w wierszu polecenia, można umieścić je w pliku konfiguracyjnym, a następnie wywołać ten plik podczas uruchamiania programu Skrypt kodowania Windows Media.

Informacje zawarte w pliku konfiguracyjnym mogą obejmować nazwę pliku wejściowego lub urządzenia audio i wideo, profil oraz dowolne opcje, które użytkownik chce określić. Ustawienia z pliku konfiguracyjnego można pominąć, wpisując poszczególne opcji w wierszu polecenia.

Pliki konfiguracyjne można tworzyć za pomocą narzędzia do edycji tekstu lub z poziomu wiersza polecenia przez dołączenie do polecenia opcji –s_config. Jeżeli dołączana jest opcja –s_config, użytkownik określa nazwę pliku, w wyniku czego wszystkie opcje z polecenia są zbierane i zapisywane w określonym pliku konfiguracyjnym. W plikach konfiguracyjnych stosuje się rozszerzenie nazwy pliku weu. Jeżeli podczas tworzenia pliku konfiguracyjnego użytkownik nie określi rozszerzenia nazwy pliku, zostanie ono dołączone automatycznie.

Tematy pokrewne

  • Zaawansowane techniki kodowania
  • Wywoływanie pliku konfiguracyjnego


Wywoływanie pliku konfiguracyjnego

transparent programu Windows Media Encoder

Aby wywołać plik konfiguracyjny

  1. Otwórz okno wiersza polecenia.
  2. W wierszu polecenia wpisz ścieżkę do folderu, w którym znajduje się plik Wmcmd.vbs. Na przykład wpisz
    cd \Program Files\Windows Media Components\Encoder
  3. Wpisz następujące polecenie, a następnie naciśnij klawisz ENTER:
    cscript.exe wmcmd.vbs –config stacja dysków:\Ścieżka\Nazwa_pliku_konfiguracyjnego

    Na przykład:

    cscript.exe wmcmd.vbs –config C:\Pliki-konfiguracyjne\Mojewideo.weu

  • Korzystanie z plików konfiguracyjnych


Korzystanie z opcji w wierszu polecenia

Poniżej wymieniono wszystkie opcje dostępne w wierszu polecenia, które można stosować wraz z poleceniami w celu uzyskania określonych wyników kodowania. Jeżeli poza opcjami określony jest profil, to opcje mają pierwszeństwo.

Aby z poziomu wiersza polecenia uzyskać dostęp do szybkiej Pomocy, należy wpisać cscript.exe wmcmd.vbs, a następnie nacisnąć klawisz ENTER.

-a_codec indeks_koderów-dekoderów

Określa koder-dekoder audio. Jeżeli koder-dekoder nie zostanie określony, stosowany jest koder-dekoder Windows Media Audio 9. Aby wyszukać kodery-dekodery i indeksy koderów-dekoderów (na przykład WMA9STD), które są zainstalowane na komputerze kodującym, należy użyć opcji -a_codecs.

-a_codecs

Wyświetla listę koderów-dekoderów audio, indeksów koderów-dekoderów oraz trybów kodowania (CBR, czyli stała szybkość transmisji bitów, i VBR, czyli zmienna szybkość transmisji bitów) obsługiwanych w koderach-dekoderach, które są zainstalowane na komputerze kodującym.

-a_content numer_trybu

Określa, czy zawartość audio stanowi głównie głos (-a_content 1), czy jest to zawartość mieszana (-a_content 2). Domyślnie stosowana jest wartość -a_content 0, czyli neutralna. W przypadku korzystania z opcji -a_content należy określić koder-dekoder Windows Media Audio 9 Voice. Więcej informacji na ten temat można znaleźć w sekcji Optymalizowanie audio dla głosu.

-a_contentedl nazwa_pliku

Jeżeli zawartość audio stanowi mieszankę głosu i utworów muzycznych, za pomocą tej opcji można określić, w których miejscach w zawartości rozpoczyna i kończy się muzyka. W przypadku korzystania z opcji -a_contentedl należy określić koder-dekoder Windows Media Audio 9 Voice i wartość -a_content 2. Więcej informacji na ten temat można znaleźć w sekcji Optymalizowanie audio dla głosu.

-adevice numer urządzenia audio

Określa urządzenie audio, które ma być źródłem. Przykładowo:

cscript.exe wmcmd.vbs -adevice 1 -vdevice 4 –broadcast 8080 –duration 480

Aby wyszukać numery urządzeń przechwytywania audio i wideo w komputerze kodującym, należy użyć opcji -devices. Opcja -duration jest wymagana przy przechwytywaniu z urządzeń.

-a_folddown6to2 kanał przestrzenny kanał środkowy kanał niskich częstotliwości

W przypadku kodowania wielokanałowego audio określa sposób automatycznej redukcji sześciu kanałów na dwa kanały w celu odtwarzania przez głośniki stereo. Można używać tylko pełnych liczb. Podane wartości, które muszą mieścić się w przedziale od 0 do 144 decybeli, są konwertowane na liczby ujemne. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-piosenki\Piosenka1.wav –output C:\Moje-piosenki-zakodowane\Piosenka1.wma -a_codec WMA9PRO -a_mode 2 -a_setting 640_48_6_24 -a_folddown6to2 3 3 12

-a_formats

Wyświetla listę formatów audio (szybkość transmisji bitów, częstotliwość próbkowania i kanały) obsługiwanych przez każdy koder-dekoder.

-a_mode numer_trybu

Określa tryb kodowania zawartości audio. Można użyć jedno- lub dwuprzebiegowego kodowania ze stałą szybkością transmisji bitów, czyli CBR (odpowiednio -a_mode 0 lub -a_mode 1), lub jednego z trybów kodowania ze zmienną szybkością transmisji bitów, czyli VBR: w oparciu o jakość (-a_mode 2), w oparciu o szybkość transmisji bitów (-a_mode 3) lub w oparciu o szczytową szybkość transmisji bitów (-a_mode 4). Więcej informacji na ten temat można znaleźć w sekcji Korzystanie z kodowania CBR lub VBR.

-a_peakbitrate maksymalna szybkość transmisji bitów

Określa maksymalną szybkość transmisji bitów (w bitach na sekundę), która ma być stosowana przy kodowaniu zawartości audio ze zmienną szybkością transmisji bitów w oparciu o szybkość szczytową. Wartość domyślna jest 1,5 raza większa od szybkości transmisji bitów audio. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moja-muzyka\Moja_piosenka.wav –output C:\Moja-muzyka-zakodowana\Moja_piosenka.wma -a_mode 4 -a_setting 80_44_2 -a_peakbitrate 300000 -a_peakbuffer 8000

-a_peakbuffer maksymalny rozmiar bufora

Określa czas buforowania zawartości audio (w milisekundach). Opcja ta jest stosowana przy kodowaniu zawartości audio ze zmienną szybkością transmisji bitów w oparciu o szybkość szczytową. Wartość domyślna to 3000 milisekund. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moja-muzyka\Moja_piosenka.wav –output C:\Moja-muzyka-zakodowana\Moja_piosenka.wma -a_mode 4 -a_setting 80_44_2 -a_peakbitrate 300000 -a_peakbuffer 8000

-a_setting szybkość transmisji bitów_częstotliwość próbkowania_kanał

Określa szybkość transmisji bitów audio, częstotliwość próbkowania i kanał na potrzeby kodowania. Jeżeli używany jest koder-dekoder Windows Media Audio 9 Professional lub Windows Media Audio 9 Lossless, opcja -a_setting określa również kodowanie 16- lub 24-bitowe (format szybkość transmisji bitów_częstotliwość próbkowania_kanał_bity na próbkę). Aby wyświetlić ustawienia obsługiwane przez każdy z koderów-dekoderów, należy użyć opcji -a_formats. Jeżeli używany jest koder-dekoder Windows Media Audio 9 Voice, wartość domyślna to 12_16_1. Jeżeli używany jest koder-dekoder Windows Media Audio 9 Professional, wartość domyślna to 128_44_2_24 (chyba że wprowadzono sesję kodowania ze zmienną szybkością transmisji bitów w oparciu o jakość – w tym przypadku wartością domyślną jest Q75_44_2_24.) Jeżeli używany jest koder-dekoder Windows Media Audio 9 Lossless, wartość domyślna to Q100_44_2_16. Jeżeli kodowana jest zawartość nieskompresowana, wartością domyślną jest 705_22_2. We wszystkich innych przypadkach wartość domyślna to 64_44_2. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-piosenki\Piosenka1.wav –output C:\Moje-piosenki-zakodowane\Piosenka1.wma –a_setting 32_44_2

Więcej informacji na temat korzystania z opcji -a_setting wraz z kodowaniem zawartości audio ze zmienną szybkością transmisji bitów w oparciu o jakość można znaleźć w sekcji Implementowanie trybu kodowania CBR lub VBR.

-audioonly

W przypadku, gdy źródłem jest plik zawierający zarówno zawartość audio, jak i wideo, opcja ta określa kodowanie tylko części audio.

-author ciąg

Określa autora zawartości; informacja ta jest wyświetlana w trakcie odtwarzania zawartości. Jeżeli w ciągu występują spacje, należy wpisać go w cudzysłowie. Maksymalna długość ciągu wynosi 255 znaków. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-piosenki\Piosenka1.wav –output C:\Moje-piosenki-zakodowane\Piosenka1.wma –author "Jan Kowalski"

-broadcast numer_portu

Określa port HTTP używany do emisji. Wartość domyślna to 8080. Jeżeli źródłem jest urządzenie, należy również uwzględnić opcję -duration. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-piosenki\Piosenka1.wav –broadcast 9090
cscript.exe wmcmd.vbs -adevice 1 -vdevice 4 –broadcast 9090 –duration 620

-config nazwa_pliku

Określa plik konfiguracyjny, który ma być używany podczas sesji kodowania. W plikach konfiguracyjnych stosowane jest rozszerzenie nazwy weu. Aby utworzyć plik konfiguracyjny, należy użyć opcji -s_config lub edytora tekstu. Więcej informacji na ten temat można znaleźć w sekcji Korzystanie z plików konfiguracyjnych. Przykładowo:

cscript.exe wmcmd.vbs –config C:\Moje-pliki-konfiguracyjne\Mój_plik_konfiguracyjny.weu

-copyright ciąg

Określa informacje o prawach autorskich dotyczące zawartości; informacje te są wyświetlane w trakcie wyświetlania zawartości. Jeżeli w ciągu występują spacje, należy wpisać go w cudzysłowie. Maksymalna długość ciągu wynosi 255 znaków. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-piosenki\Piosenka1.wav –output C:\Moje-piosenki-zakodowane\Piosenka1.wma –copyright "Jan Kowalski 2001"

-description ciąg

Umożliwia dołączenie opisu zawartości; informacje te są wyświetlane w trakcie wyświetlania zawartości. Jeżeli w ciągu występują spacje, należy wpisać go w cudzysłowie. Maksymalna długość ciągu wynosi 255 znaków. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-piosenki\Piosenka1.wav –output C:\Moje-piosenki-zakodowane\Piosenka1.wma –description "Kolekcja moich ulubionych utworów muzycznych"

-devices

Wyświetla listę urządzeń audio i wideo (i skojarzonych z nimi numerów urządzeń) w komputerze kodującym. Z numerów urządzeń można korzystać przy przechwytywaniu zdarzenia na żywo. (Więcej informacji na ten temat można znaleźć w opisach opcji -adevice i -vdevice.)

-duration czas

Określa czas kodowania w sekundach. Z opcji tej należy korzystać, jeżeli źródłem są urządzenia. Kodowanie rozpoczyna się na początku emisji i zatrzymuje po upływie określonego czasu. Rzeczywisty czas kodowania może się różnić o kilka sekund od podanego. Przykładowo:

cscript.exe wmcmd.vbs -adevice 1 -vdevice 4 –broadcast 8080 –duration 480

-input nazwa_pliku lub nazwa_folderu

Określa nazwę pliku lub folderu. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi -output C:\Moje-klipy-zakodowane\Mój_plik.wmv
cscript.exe wmcmd.vbs –input C:\Moje-klipy -output C:\Moje-klipy-zakodowane

Jeżeli nazwa pliku lub folderu zawiera spacje, należy wpisać ją w cudzysłowie, przykładowo "mój przykład.avi".

Określając w poleceniu sam plik źródłowy, można wyświetlić statystykę na jego temat. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi

-loadprofile nazwa_pliku_profilu

Określa nazwę pliku właściwą dla programu Windows Media Encoder lub niestandardowego profilu, który ma być używany w sesji kodowania. W profilach stosowane jest rozszerzenie nazwy pliku prx. (Aby skorzystać z jednego ze wstępnie zdefiniowanych profili dostarczanych wraz ze Skryptem kodowania Windows Media, należy użyć opcji -profile.) Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi -output C:\Moje-klipy-zakodowane\Mój_plik.wmv -loadprofile C:\Moje-profile\500kbps_peakVBR.prx

Więcej informacji na temat tworzenia profilu można znaleźć w sekcji Korzystanie z profili.

-output nazwa_pliku lub folder

Określa nazwę wyjściowego pliku lub folderu. Jeśli określony folder nie istnieje, zostanie utworzony. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-piosenki\Piosenka1.wav –output c:\Moje-piosenki-zakodowane\Moje-piosenki.wma
cscript.exe wmcmd.vbs –input C:\Moje-piosenki –output C:\Moje-piosenki-zakodowane

-outputstring ciąg

Podczas kodowania plików w folderze to polecenie powoduje dołączenie tekstu wpisanego jako ciąg do nazwy każdego pliku wyjściowego. Ciąg występuje przed rozszerzeniem nazwy pliku wma lub wmv. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-piosenki –output C:\Moje-piosenki-zakodowane –outputstring zakodowane

-pixelratio x y

Określa współczynnik proporcji pikseli w zakodowanym wideo. Opcję tę należy stosować, jeżeli w źródle wideo występują niekwadratowe piksele, a użytkownik chce zachować współczynnik proporcji pikseli z tego źródła. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi -output C:\Moje-klipy-zakodowane\Mój_plik.wmv -pixelratio 8 9

-pixelformat format

Określa format pikseli zakodowanego wideo. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi -output C:\Moje-klipy-zakodowane\Mój_plik.wmv -pixelformat RGB32

Listę formatów pikseli można znaleźć w sekcji Obsługiwane formaty pikseli.

-profile indeks_profilów

Określa wstępnie zdefiniowany profil sesji kodowania. (Aby skorzystać z niestandardowego profilu, należy użyć opcji -loadprofile.) Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi -output C:\Moje-klipy-zakodowane\Mój_plik.wmv -profile av700pal

Listę profilów można znaleźć w sekcji Korzystanie z profili.

-rating ciąg

Określa klasyfikację zawartości; informacja ta jest wyświetlana w trakcie odtwarzania zawartości. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi –output C:\Moje-klipy-zakodowane\Mój_plik.wmv –rating PG

-saveprofile nazwa_profilu

Zapisuje inne opcje w poleceniu jako profil do późniejszego użycia. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi -output C:\Moje-klipy-zakodowane\Mój_plik.wmv –v_clip 4 6 2 8 –v_codec WMV8 -v_bitrate 100000 –v_keydist 20 –v_framerate 24 -saveprofile C:\Moje-profile\100kbps.prx

Więcej informacji na temat tworzenia profilu można znaleźć w sekcji Korzystanie z profili.

-silent

Zapobiega wyświetlaniu statystyki kodowania po zakończeniu tego procesu.

-s_config nazwa_pliku

Tworzy plik konfiguracyjny. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi –output C:\Moje-klipy-zakodowane\Mój_plik.wmv –s_config C:\Pliki-konfiguracyjne\Moje_utwory_wideo.weu

Plik konfiguracyjny można również utworzyć za pomocą edytora tekstu. Po utworzeniu pliku konfiguracyjnego można go wywołać opcją -config. Więcej informacji na ten temat można znaleźć w sekcji Korzystanie z plików konfiguracyjnych.

-time czas rozpoczęcia czas zakończenia

Określa w milisekundach właściwy czas rozpoczęcia i zakończenia kodowania w obrębie pliku wejściowego. (Jeżeli źródłem jest plik, należy użyć opcji -time. W przypadku przechwytywania zdarzenia na żywo z urządzeń należy użyć opcji -duration.) Jeżeli dokładny czas zakończenia nie jest znany, należy zamiast niego wpisać wartość end. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi –output C:\Moje-klipy-zakodowane\Mój_plik.wmv –time 10000 20000
cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi -output C:\Moje-klipy-zakodowane\Mój_plik.wmv –time 10000 end

-title ciąg

Określa tytuł zawartości; informacja ta jest wyświetlana w trakcie odtwarzania zawartości. Jeżeli w ciągu występują spacje, należy wpisać go w cudzysłowie. Maksymalna długość ciągu wynosi 255 znaków. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-piosenki\Piosenka1.wav –output C:\Moje-piosenki-zakodowane\Piosenka1.wma –title "Moje ulubione utwory muzyczne"

-videoonly

W przypadku, gdy źródłem jest plik zawierający zarówno zawartość audio, jak i wideo, opcja ta określa kodowanie tylko części wideo.

-v_bitrate szybkość transmisji bitów

Określa żądaną szybkość transmisji bitów w bitach na sekundę. Wartość domyślna wynosi 250 000. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi –output C:\Moje-klipy-zakodowane\Mój_plik.wmv –v_bitrate 100000

-v_buffer rozmiar

Określa część wideo (w milisekundach), która przed odtworzeniem jest przechowywana w pamięci. Wartość domyślna to 5 000 milisekund. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi –output C:\Moje-klipy-zakodowane\Mój_plik.wmv –v_buffer 1000

-v_clip lewo góra prawo dół

Określa obszar obrazu, który ma być wycięty ze źródłowego wideo. Jeżeli wartość określona dla prawej strony jest równa 0 lub większa od szerokości, to jest ignorowana i następuje ponowne przypisanie wartości szerokości. Jeżeli wartość określona dla dołu jest równa 0 lub większa od wysokości, to jest ignorowana i następuje ponowne przypisanie wartości wysokości. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi –output C:\Moje-klipy-zakodowane\Mój_plik.wmv –v_clip 4 6 2 8

-v_codec indeks_koderów-dekoderów

Określa koder-dekoder wideo. Jeżeli koder-dekoder nie zostanie określony, stosowany jest koder-dekoder Windows Media Video 9. Aby wyszukać kodery-dekodery i indeksy koderów-dekoderów (na przykład WMS9), które są zainstalowane na komputerze kodującym, należy użyć opcji -v_codecs.

-v_codecs

Wyświetla listę koderów-dekoderów wideo i indeksów koderów-dekoderów, które są zainstalowane na komputerze kodującym.

-vdevice numer urządzenia wideo

Określa urządzenie wideo, które ma być źródłem. Przykładowo:

cscript.exe wmcmd.vbs -adevice 1 -vdevice 4 –broadcast 8080 –duration 480

Aby wyszukać numery urządzeń przechwytywania audio i wideo w komputerze kodującym, należy użyć opcji -devices. Opcja -duration jest wymagana przy przechwytywaniu z urządzeń.

-v_framerate szybkość

Określa szybkość klatek, z jaką kodowane jest wideo. Szybkość można określić jako liczbę całkowitą lub zmiennoprzecinkową. Wartość domyślna to 30 klatek na sekundę. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi –output C:\Moje-klipy-zakodowane\Mój_plik.wmv –v_framerate 24

-v_height wysokość

Określa kodowaną wysokość klatki w pikselach. Wartością domyślną jest wysokość źródłowego wideo. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi –output C:\Moje-klipy-zakodowane\Mój_plik.wmv –v_height 480

-v_keydist czas

Określa liczbę sekund między klatkami kluczowymi. Wartość domyślna to 10 sekund.

-v_mode numer_trybu

Określa tryb kodowania zawartości wideo. Można użyć jedno- lub dwuprzebiegowego kodowania ze stałą szybkością transmisji bitów, czyli CBR (odpowiednio -v_mode 0 lub -v_mode 1), lub jednego z trybów kodowania ze zmienną szybkością transmisji bitów, czyli VBR: w oparciu o jakość (-v_mode 2), w oparciu o szybkość transmisji bitów (-v_mode 3) lub w oparciu o szczytową szybkość transmisji bitów (-v_mode 4). Więcej informacji na ten temat można znaleźć w sekcji Korzystanie z kodowania CBR lub VBR.

-v_peakbitrate maksymalna szybkość transmisji bitów

Określa maksymalną szybkość transmisji bitów (w bitach na sekundę), która ma być stosowana przy kodowaniu zawartości wideo ze zmienną szybkością transmisji bitów w oparciu o szybkość szczytową. Wartość domyślna jest 1,5 raza większa od szybkości transmisji bitów wideo. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi –output C:\Moje-klipy-zakodowane\Mój_plik.wmv -v_mode 4 -v_bitrate 100000 -v_peakbitrate 300000 -v_peakbuffer 8000

-v_peakbuffer maksymalny rozmiar buforu

Określa czas buforowania zawartości wideo (w milisekundach), który ma być stosowany przy kodowaniu ze zmienną szybkością transmisji bitów w oparciu o szybkość szczytową. Wartość domyślna to 5 000 milisekund. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi –output C:\Moje-klipy-zakodowane\Mój_plik.wmv -v_mode 4 -v_bitrate 100000 -v_peakbitrate 300000 -v_peakbuffer 8000

-v_performance liczba

Określa ustawienie wydajności sprzętu na potrzeby komputera kodującego. Opcja ta jest przeznaczona do wykorzystania przy kodowaniu za pomocą kodera-dekodera Windows Media Video 9. Jeżeli użytkownik nie określi wartości, stosowane są wartości domyślne kodera-dekodera. Możliwe wartości to: 0, 20, 40, 60, 80 i 100, przy czym 100 odpowiada najwyższej jakości. Więcej informacji na temat ustawień wydajności można znaleźć w Pomocy programu Windows Media Encoder.

-v_preproc numer_filtru

Określa filtr wstępnego przetwarzania, który ma być zastosowany do zawartości. Listę możliwych wartości można znaleźć w sekcji Optymalizowanie wideo i audio.

-v_profile indeks_zgodności_urządzeń

Określa kategorię złożoności zakodowanej zawartości. Opcji tej należy użyć, jeżeli zawartość ma być odtwarzana na urządzeniu sprzętowym innym niż komputer. Część urządzeń sprzętowych obsługuje tylko niektóre kategorie. (Więcej informacji na ten temat można znaleźć w dokumentacji dostarczonej wraz z urządzeniem.) Jeżeli do polecenia nie zostanie dodana opcja -v_profile, prawidłowe ustawienie złożoności podczas kodowania będzie wybierane automatycznie. Możliwe wartości to: SP (prosta), MP (główna) lub CP (złożona). Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi –output C:\Moje-klipy-zakodowane\Mój_plik.wmv –v_profile SP

Program Windows Media Encoder udostępnia profile sprzętowe przeznaczone dla różnych typów urządzeń sprzętowych. Więcej informacji na temat tych profili można znaleźć w Pomocy programu Windows Media Encoder.

-v_quality numer_jakości

Określa jakość obrazu w zakodowanym wideo. Jakość obrazu mieści się w zakresie od 0 do 100. W trybach wideo ze stałą szybkością transmisji bitów (-v_mode 0 lub –v_mode 1) wartość 0 oznacza najbardziej wygładzony ruch, a wartość 100 — najbardziej wyrazisty obraz. Wartość domyślna to 75. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi –output C:\Moje-klipy-zakodowane\Mój_plik.wmv –v_mode 0 –v_quality 40

W trybie wideo ze zmienną szybkością transmisji bitów opartym na jakości (-v_mode 2) wartość ta odpowiada docelowej jakości obrazu w całej sekwencji. Wartość domyślna to 95. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi –output C:\Moje-klipy-zakodowane\Mój_plik.wmv –v_mode 2 –v_quality 95

-v_width szerokość

Określa kodowaną szerokość klatki w pikselach. Wartością domyślną jest szerokość źródłowego wideo. Przykładowo:

cscript.exe wmcmd.vbs –input C:\Moje-klipy\Mój_plik.avi –output C:\Moje-klipy-zakodowane\Mój_plik.wmv –v_width 640

-wme nazwa pliku

Określa istniejący plik sesji kodowania. Przykładowo:

cscript.exe wmcmd.vbs –wme C:\Moje-sesje\Mój_plik_sesji.wme

  • Zaawansowane techniki kodowania


Obsługiwane formaty pikseli

Podczas używania opcji –pixelformat należy określić jeden z następujących formatów pikseli.

  • I420
  • IYUV
  • RGB24
  • RGB32
  • RGB555
  • RGB565
  • RGB8
  • UYVY
  • YUY2
  • YV12
  • YVU9
  • YVYU

  • Korzystanie z opcji wiersza polecenia


Często zadawane pytania

  1. Czy mogę używać rozszerzonych plików .avi z programem Skrypt kodowania Windows Media?

    Tak. Program Skrypt kodowania Windows Media obsługuje specyfikację formatu rozszerzonych plików .avi i może kodować pliki .avi o rozmiarze większym niż 2 gigabajty (GB).

  2. Czy mogę kodować skompresowane pliki Windows Media z rozszerzeniami nazwy pliku .wma i .wmv, aby otrzymać inną szybkość transmisji bitów?

    Tak. Jednak lepsze rezultaty osiąga się, ponownie kodując oryginalny plik źródłowy i określając żądaną szybkość transmisji bitów za pomocą opcji –v_bitrate w przypadku wideo lub –a_setting w przypadku audio.

  3. Ustawiam opcję –v_bitrate w jedno i dwuprzebiegowym trybie CBR oraz trybie VBR w oparciu o szybkość transmisji bitów (-v_mode 0, 1 i 3), a szybkość transmisji bitów w skompresowanym klipie jest znacznie niższa niż określona. Czy jest to błąd?

    Nie. Jeśli klip lub segment w klipie jest łatwy do zakodowania w docelowej szybkości transmisji bitów (na przykład ustawienie szybkości transmisji bitów jest bardzo wysokie a rozdzielczość jest niska), koder-dekoder nie wymaga całej dostępnej przepustowości do skompresowania zawartości.

  4. Ustawiam opcję –v_bitrate dla trybu VBR w oparciu o szybkość transmisji bitów (-v_mode 3), a szybkość transmisji bitów jest znacznie wyższa niż określona. Czy jest to błąd?

    Nie. Podczas kodowania zawartości z wykorzystaniem opcji –v_mode 3 klatki nie są gubione. Jeśli klip lub segment klipu jest trudny do zakodowania dla docelowej szybkości transmisji bitów (na przykład ustawienie szybkości transmisji bitów jest niskie a rozdzielczość jest wysoka), koder-dekoder wymaga większej przepustowości w celu skompresowania zawartości.

  5. W jakiej kolejności program Skrypt kodowania Windows Media dzieli na klipy, wstępnie przetwarza i zmienia rozmiar mojej zawartości?

    Podział na klipy jest pierwszym krokiem i jest wykonywany na źródle. Wstępny podział na klipy sprawia, że proces kodowania jest bardziej efektywny – wszystkie niechciane fragmenty wideo są usuwane przed kodowaniem. Przetwarzanie wstępne, na przykład stosowanie filtru usuwanie przeplotu lub inverse telecine, jest wykonywane jako drugie w kolejności. Następnie ustawiany jest rozmiar wyjściowy zakodowanego wideo.

  6. Czy mogę użyć programu Skrypt kodowania Windows Media do kodowania pliku o wielu szybkościach transmisji bitów (MBR), tak aby można było przesyłać zawartość strumieniowo do użytkowników, którzy mają różne szybkości połączeń?

    Można kodować dowolny plik MBR, jeśli zostanie użyty profil MBR utworzony za pomocą programu Windows Media Encoder.

  7. Używam ustawienia -v_quality do skonfigurowania jakości obrazu na wartość 95, a następnie 96. Osiągam ten sam rezultat przy obu ustawieniach. Czy jest to normalne?

    Tak. Część ustawień -v_quality jest odwzorowywana wewnętrznie na tę samą wartość jakości obrazu. Aby zauważyć zmianę w jakości obrazu, znacznie zwiększ lub zmniejsz ustawienie -v_quality.

  • Skrypt kodowania Windows Media


Słownik

Aby wyszukać termin w słowniku, należy kliknąć literę alfabetu, która jest pierwszą literą szukanego terminu.

Można również przeczytać definicje terminów słownika w tekście Pomocy, klikając podkreślone łącza do terminów słownika. Po kliknięciu łącza słownika, termin słownika i jego definicja zostaną wyświetlone w oknie podręcznym. Aby zamknąć okno, należy kliknąć w dowolnym miejscu ekranu.

A | B | C | D | E | F | G | H | I | J | K | L | M
N | O | P | Q | R | S | T | U | V | W | X | Y | Z

Symbole

.prx

Rozszerzenie nazwy pliku profilu.

.weu

Rozszerzenie nazwy pliku konfiguracyjnego używanego przez program Skrypt kodowania Windows Media.

.wma

Rozszerzenie nazwy pliku audio w formacie Windows Media. Zawartość audio pliku jest zakodowana za pomocą kodera-dekodera Windows Media Audio.

.wme

Rozszerzenie nazwy pliku sesji programu Windows Media Encoder.

.wmv

Rozszerzenie nazwy pliku wideo w formacie Windows Media.

Powrót do początku

A

Anons

Metaplik pakietu Windows Media udostępniający odtwarzaczowi informacje wymagane do odebrania zawartości. Pliki anonsów zawierają skrypty języka Extensible Markup Language (XML).

Audio Video Interleaved (AVI)

Format plików multimedialnych służących do przechowywania dźwięku i obrazu w formacie RIFF.

Audio wielokanałowe

System reprodukcji dźwięku, w którym obsługiwanych jest kilka, zazwyczaj więcej niż dwa, kanałów dźwięku. Na przykład termin wielokanałowe audio 5.1 odnosi się do systemu dźwięku przestrzennego, w którym występuje pięć kanałów podstawowych i jeden kanał głośnika niskotonowego.

AVI

Zobacz definicję dla: Audio Video Interleaved (AVI)

Powrót do początku

B

Bez przeplotu

Połączenie pól przeplotu w klatce wideo, dzięki czemu podczas odtwarzania linie klatki wideo są rysowane po kolei.

Zobacz też: Z przeplotem

Buforowanie typu postroll

Rozszerzenie rozmiaru kodowanego wideo o określoną liczbę klatek.

Buforowanie typu preroll

Przechwytywanie lub odtwarzanie liczby klatek wideo lub porcji danych audio przez rozpoczęciem kodowania lub renderowania w celu ustabilizowania źródła. Termin używany też jako rzeczownik opisujący porcję danych, która będzie w ten sposób buforowana.

Powrót do początku

C

CBR

Zobacz definicję dla: Stała szybkość transmisji bitów (CBR)

Czas oczekiwania

Opóźnienie występujące podczas przetwarzania lub dostarczania danych.

Częstotliwość próbkowania

Częstotliwość próbkowania. Wyższa częstotliwość próbkowania (czyli więcej próbek pobranych w jednostce czasu) powoduje, że wynik cyfrowy jest bliższy oryginałowi.

Powrót do początku

E

Edytor profili

Narzędzie dostarczane z programem Windows Media Encoder, które służy do tworzenia i edytowania profili kodowania.

Zobacz też: Profil

Emisja pojedyncza

Metoda używana przez serwery multimediów do dostarczania zawartości do połączonych klientów, w której każdy klient odbiera osobny strumień. Żaden inny klient nie ma dostępu do tego strumienia.

Powrót do początku

F

Format piksela

Rozmiar i rozmieszczenie składników koloru piksela. Format jest określony przez całkowitą liczbę bitów używanych na jeden piksel i liczbę bitów używaną do przechowywania składowych kolorów: zielonego, czerwonego, niebieskiego i alfa.

Format strumieniowy

Informacje o właściwościach strumienia, takie jak użyte kodery-dekodery, szybkość i rozmiar klatek. Odtwarzacz używa formatu strumieniowego do dekodowania strumienia.

Format Windows Media

Format używany przez technologie Microsoft Windows Media (lub produkty firm trzecich zawierające licencjonowaną technologię Windows Media) do publikowania, składowania, edytowania, dystrybuowania, przesyłania strumieniowego lub odtwarzania zawartości opartej na osi czasu.

Powrót do początku

I

IEEE 1394

Zobacz definicję dla: Institute of Electrical and Electronics Engineers (IEEE) 1394

Institute of Electrical and Electronics Engineers (IEEE) 1394

Standard magistrali szeregowej o wysokiej szybkości oferujący ulepszoną łączność między komputerem a szeroką gamą urządzeń, łącznie z konsumenckimi urządzeniami audio/wideo, dodatkowymi urządzeniami magazynowania, innymi komputerami i urządzeniami przenośnymi.

Inteligentne przesyłanie strumieniowe

Typ przesyłania strumieniowego, który wykrywa warunki w sieci i dostosowuje właściwości strumienia audio lub wideo w celu uzyskania najlepszej jakości.

Internet Protocol w wersji 6 (IPv6)

Zweryfikowana wersja protokołu Internet Protocol (IP) przeznaczona do zwiększenia liczby adresów w sieci Internet. Ulepszenia obejmują 128-bitowy rozmiar adresu IP, rozszerzone możliwości routingu oraz obsługę uwierzytelniania i prywatności.

Inverse telecine

Służy do usuwania klatek, które zostały dodane podczas konwersji 24-klatkowego filmu do filmu wideo o szybkości 30 klatek na sekundę.

IPv6

Zobacz definicję dla: Internet Protocol w wersji 6 (IPv6)

Powrót do początku

K

Klatka kluczowa

Klatka wideo zawierająca wszystkie dane wymagane do skonstruowania obrazu bez odniesień do poprzednich klatek.

Zobacz też: Klatka różnicowa

Klatka różnicowa

Klatka wideo, która zawiera tylko zmiany w porównaniu do poprzedniej klatki. Odwrotnie, klatka kluczowa zawiera wszystkie dane wymagane do skonstruowania takiej klatki.

Kod czasowy

Sygnał cyfrowy stosowany dla strumienia. Sygnał przypisuje do każdej klatki wideo liczbę, która przedstawia godziny, minuty, sekundy i klatki.

Koder-dekoder

Inna nazwa to kompresor/dekompresor. Oprogramowanie lub sprzęt używane do kompresowania i dekompresowania multimediów cyfrowych.

Koder-dekoder Windows Media Audio

Koder-dekoder używany do kompresji i dekompresji strumieni audio.

Koder-dekoder Windows Media Screen

Koder-dekoder używany do kompresji i dekompresji sekwencji obrazów ekranu.

Koder-dekoder Windows Media Video

Koder-dekoder używany do kompresji i dekompresji strumieni wideo.

Kodowanie

Konwersja zawartości audio lub wideo do określonego formatu cyfrowego.

Kodowanie dwuprzebiegowe

Metoda kodowania, w której zawartość jest analizowana podczas pierwszego przebiegu, a podczas drugiego jest kodowana. Zobacz też kodowanie jednoprzebiegowe.

Kodowanie jednoprzebiegowe

Metoda kodowania, w której zawartość jest analizowana i kompresowana podczas jednego przebiegu kodera.

Zobacz też: Kodowanie dwuprzebiegowe

Kompresja

Proces usuwania nadmiarowych danych z cyfrowych plików multimedialnych lub strumienia multimediów cyfrowych w celu zmniejszenia jego rozmiaru lub lepszego wykorzystania przepustowości.

Kompresja bezstratna

Proces kompresji danych, w którym informacje są organizowane w bardziej zwartej formie i są przywracane do oryginalnego stanu podczas dekompresji.

Kompresja stratna

Proces kompresji danych, w którym informacje uznane za niewymagane są usuwane i nie można ich przywrócić podczas dekompresji. Zazwyczaj używana z plikami danych audio i wideo, w których akceptowany jest nieznaczny spadek jakości.

Powrót do początku

L

Letterbox

Format wyświetlania wideo, w którym czarne paski są wyświetlane u dołu i u góry odtwarzanego obrazu wideo. Format letterbox zachowuje oryginalny współczynnik proporcji obrazu podczas wyświetlania w oknie o innym współczynniku proporcji.

Licencja

Dane dołączone do chronionej zawartości, opisujące sposób używania zawartości.

Powrót do początku

M

MBR

Zobacz definicję dla: Wiele szybkości transmisji bitów (MBR)

Metadane

Dane dotyczące danych. Tytuł, temat, autor i rozmiar są przykładami metadanych pliku.

Metaplik pakietu Windows Media

W technologii Windows Media Technologies, plik zawierający informacje o plikach pakietu Windows Media i ich prezentacji. Rozszerzenia nazw metaplików pakietu Windows Media obejmują .asx, .wax, .wvx, .wmx i .nsc.

Modulacja kodowo-impulsowa (PCM)

Technika digitalizacji dźwięku w nieskompresowanym formacie, polegająca na przypisywaniu wartości do amplitudy sygnału w ustalonych interwałach.

Multiemisja

Metoda dostarczania zawartości, w której pojedynczy strumień jest przesyłany z serwera multimediów do wielu klientów. Klienci nie nawiązują połączenia z serwerem. Zamiast tego serwer wysyła poprzez sieć pojedynczą kopię strumienia do routerów obsługujących multiemisję, które replikują dane. Klienci mogą potem odebrać strumień, monitorując określony port i adres IP multiemisji.

Powrót do początku

N

Nagłówek

Część struktury pliku, która zawiera informacje wymagane przez aplikację do dekompresowania i renderowania zawartości. Nagłówek w pliku chronionym zawiera też informacje wymagane do pobrania licencji.

National Television Standards Committee (NTSC)

Wiodący standard telewizyjny w Stanach Zjednoczonych i Japonii. W standardzie NTSC wyświetlanych jest 30 klatek na sekundę z przeplotem, przy rozdzielczości 525 linii.

NTSC

Zobacz definicję dla: National Television Standards Committee (NTSC)

Powrót do początku

P

PAL

Zobacz definicję dla: Phase Alternating Line (PAL)

PCM

Zobacz definicję dla: Modulacja kodowo-impulsowa (PCM)

Pętla

Ciągłe powtarzanie strumienia.

Phase Alternating Line (PAL)

Wiodący standard telewizyjny w Chinach i Europie. W standardzie PAL wyświetlanych jest 25 klatek na sekundę z przeplotem, przy rozdzielczości 625 linii.

Plik formatu strumieniowego

Plik używany przez odtwarzacz do dekodowania strumienia multiemisji.

Zobacz też: Format strumieniowy

Plik konfiguracyjny

Plik tekstowy używany przez Skrypt kodowania Windows Media określający zawartość, która będzie kodowana i opcje wiersza poleceń, które zostaną wywołane.

Plik pakietu Windows Media

Plik zawierający dane audio, wideo lub skryptów w formacie Windows Media. W zależności od zawartości i przeznaczenia pliki pakietu Windows Media mają różne rozszerzenia nazw, takie jak: .wma, .wme, .wms, .wmv, .wmx, .wmz lub .wvx.

Podpis

Tekst towarzyszący obrazom lub filmom wideo, będący dodatkowym opisem lub transkrypcją tekstu mówionego.

Polecenia skryptów

Nazwane dane skojarzone z określonym czasem w zawartości opartej na formacie Windows Media. Dane mogą być wykorzystywane przez odtwarzacze do wykonania określonej akcji, takiej jak otwieranie strony sieci Web.

Profil

Grupa ustawień pasujących do typu zawartości i szybkości przesyłania bitów w odpowiednich koderach-dekoderach audio i wideo.

Próbkowanie

Proces pomiaru amplitudy sygnału analogowego w regularnych odstępach czasu w celu konwersji sygnału analogowego do formatu cyfrowego.

Przepustowość

Zdolność sieci do przesyłania określonej ilości danych w określonym czasie.

Punkt publikacji

Zorganizowana lokalizacja w pamięci, która dokonuje translacji żądań klientów dotyczących zawartości na ścieżkę fizyczną na serwerze przechowującym zawartość. Punkt publikacji w istocie działa jako przekierowywacz.

Powrót do początku

R

RGB

Model koloru opisujący informacje o kolorze za pomocą wartości intensywności kolorów – czerwonego (R), zielonego (G) i niebieskiego (B) – z których powstaje kolor.

Powrót do początku

S

Stała szybkość transmisji bitów (CBR)

Charakterystyka strumienia danych, w której szybkość transmisji bitów pozostaje prawie jednorodna w całym strumieniu.

Zobacz też: Zmienna szybkość transmisji bitów (VBR)

Strumień

Multimedia cyfrowe, które są dostarczane w sposób ciągły przez sieci.

Szybkość klatek

Liczba klatek wideo wyświetlanych w ciągu sekundy. Większa szybkość klatek przeważnie sprawia, że ruch w filmie jest płynniejszy.

Szybkość transmisji bitów

Liczba bitów przesyłanych w ciągu sekundy.

Ściąganie

Dostarczanie danych do klienta tylko na jego żądanie.

Powrót do początku

T

Telecine

System konwersji filmu do wideo, który dodaje ramki do wideo w celu kompensacji różnic w szybkościach klatek między filmem a wideo.

Powrót do początku

U

UDP

Zobacz definicję dla: User Datagram Protocol (UDP)

UNC

Zobacz definicję dla: Universal Naming Convention (UNC)

Universal Naming Convention (UNC)

Pełna nazwa zasobu w sieci. Odpowiada składni \\nazwaserwera\nazwaudziału, gdzie nazwaserwera jest nazwą serwera, a nazwaudziału jest nazwą udostępnionego zasobu. Nazwy plików i katalogów w konwencji UNC mogą zawierać również ścieżkę do katalogu pod nazwą zasobu, według następującej składni: \\nazwaserwera\nazwaudziału\katalog\nazwapliku.

User Datagram Protocol (UDP)

Protokół transportu bezpołączeniowego w stosie protokołu TCP/IP, używany gdy dopuszczalna jest utrata niektórych pakietów, na przykład w strumieniach multimediów cyfrowych.

Powrót do początku

V

VBR

Zobacz definicję dla: Zmienna szybkość transmisji bitów (VBR)

Powrót do początku

W

Wiele szybkości transmisji bitów (MBR)

Charakterystyka strumienia dźwięku, w której zawartość jest kodowana z kilkoma różnymi szybkościami transmisji bitów w celu optymalizacji dostarczania zawartości.

Współczynnik proporcji

Stosunek szerokości obrazu do jego wysokości.

Wypychanie

Dostarczanie danych do klienta bez żądania klienta dotyczącego tych danych.

Powrót do początku

Y

YUV

Model koloru opisujący informacje o kolorze za pomocą składników jego jaskrawości (luminancja lub Y) i koloru (chrominancja lub U i V).

Powrót do początku

Z

Z przeplotem

Wyświetlanie klatki wideo w dwóch polach. Jedno pole zawiera parzyste linie klatki, a drugie pole zawiera nieparzyste linie klatki. Podczas odtwarzania najpierw wyświetlane są linie jednego pola, a następnie linie drugiego pola.

Zakres dynamiki

Różnica (w decybelach) między najcichszym i najgłośniejszym dźwiękiem w pojedynczym elemencie zawartości audio.

Zawartość

Audio, wideo, obrazy, tekst lub inne informacje znajdujące się w cyfrowym pliku multimedialnym lub strumieniu.

Zmienna szybkość transmisji bitów (VBR)

Charakterystyka strumienia danych, w której szybkość transmisji bitów zmienia się w zależności od złożoności danych.

Znacznik

Ciąg tekstowy skojarzony z odpowiednim czasem w zawartości opartej na formacie Windows Media. Znaczniki często wskazują odpowiednie punkty rozpoczęcia odtwarzania, takie jak początek nowej sceny.

Źródło

Zawartość audio i wideo, która może zostać przechwycona lub zakodowana z pliku lub urządzeń zainstalowanych w komputerze.

Powrót do początku

© 2002 Microsoft Corporation. Wszelkie prawa zastrzeżone.


Uwaga prawna

Informacje zawarte w tym dokumencie, w tym również adresy URL i inne odwołania do witryn sieci Web, mogą ulec zmianie bez powiadomienia. O ile nie zaznaczono inaczej, przykładowe firmy, organizacje, produkty, osoby i zdarzenia opisane w tym dokumencie są fikcyjne i istnienie jakiegokolwiek związku z rzeczywistymi firmami, organizacjami, produktami, osobami lub zdarzeniami nie jest zamierzone i nie powinno być zakładane. Za przestrzeganie wszelkich odpowiednich praw autorskich odpowiada użytkownik. Niezależnie od praw wchodzących w zakres praw autorskich, żadnej części tego dokumentu nie można powielać, przechowywać lub wprowadzać do systemów wyszukiwania informacji ani też przekazywać w żadnej formie lub za pomocą jakichkolwiek urządzeń (elektronicznych, mechanicznych, fotokopiujących, rejestrujących lub innych) w jakimkolwiek celu, bez pisemnej zgody firmy Microsoft Corporation.

Firma Microsoft może posiadać patenty, zgłoszenia patentowe, znaki towarowe, prawa autorskie lub inne prawa własności intelektualnej dotyczące treści tego dokumentu. Z wyjątkiem przypadków wyraźnie określonych w jakiejkolwiek pisemnej umowie licencyjnej firmy Microsoft, udostępnienie tego dokumentu nie jest równoznaczne z udzieleniem użytkownikowi jakichkolwiek licencji na wymienione patenty, znaki towarowe, prawa autorskie lub inną własność intelektualną.

© 2000-2002 Microsoft Corporation. Wszelkie prawa zastrzeżone.

Microsoft, MS-DOS, Windows, Windows Media, Windows NT, ActiveSync, ActiveX, Direct3D, DirectDraw, DirectInput, DirectMusic, DirectPlay, DirectShow, DirectSound, DirectX, FrontPage, JScript, Microsoft Press, MSN, NetShow, Outlook, PowerPoint, Visual Basic, Visual C++, Visual InterDev, Visual J++, Visual Studio, WebTV, Win32 i Win32s są zastrzeżonymi znakami towarowymi lub znakami towarowymi firmy Microsoft Corporation, zarejestrowanymi w Stanach Zjednoczonych i/lub w innych krajach.

Nazwy rzeczywistych firm i produktów wymienionych w tym dokumencie mogą być znakami towarowymi ich odpowiednich właścicieli.